phpmyadmin – 2002 – El servidor no esta respondiendo (o el socket del servidor MySQL local no esta configurado correctamente)

Este problema se está dando en servidores con CPanel cuando se intenta acceder al phpmyadmin para gestionar las bases de datos Mysql desde el WHM, aunque en principio se podría dar en cualquier instalación.

Me he encontrado con este error en las últimas versiones CURRENT y RELEASE, así que no se si sólo serán estas versiones u otras estarán también afectadas.

El error sale en el explorador cuando pinchas sobre la acción de acceder al phpmyadmin

Para solventarlo:

Vamos al directorio de phpMyadmin, hacemos una copia de seguridad del fichero de configuración por lo que pueda pasar…

Editamos el fichero y cambiamos las siguientes líneas para dejarlas tal y como se indica debajo:

Y vuestro podéis utilizar vuestro phpMyadmin para administrar fácilmente vuestras bases de datos.

PD: al parecer, cuando se actualiza CPanel en el servidor, el error vuelve a aparecer… Supongo que será hasta que los de CPanel lo arreglen definitivamente.

This entry was posted in cpanel, mysql, phpmyadmin and tagged , , . Bookmark the permalink.

18 Responses to phpmyadmin – 2002 – El servidor no esta respondiendo (o el socket del servidor MySQL local no esta configurado correctamente)

  1. Enzo says:

    Hola innteresante el post, a ver si me puede ayudar, cuando inicio con una cuenta de mi vps, al cpanel, cargo el phpmyadmin, me aparece un error de phpmyadmin que pone:

    PHPMYADMIN – ERROR
    Hubo errores al iniciar la sesi?n. Por favor, revise los errores en la bit?cora de su PHP y/o servidor web y configure correctamente su instalaci?n PHP.

    Si alguien sabe como solucionarlo ahi esta mi email.
    gracias

  2. Adrian Perez says:

    Revisa los logs de php a ver que errores salen.
    También puedes intentar cambiar la configuración de phpmyadmin con algo parecido a lo que indico en este post y de este modo evitar este error.

    Saludos.

  3. diory says:

    bueno yo no entiedo como solucionar el prblema nose que archivo modificarlepara poder trabajar este error me sale tanbien 2002 – El servidor no esta respondiendo (o el socket del servidor MySQL local no esta configurado correctamente)

  4. Adrian Perez says:

    Hola diory,

    El error puede ser por varios motivos.
    Revisa que tienes arrancado el MySQL.
    Tienes CPanel? Prueba esta solución si es así:
    http://matnews.info/2008/09/15/phpmyadmin-error-2002-otra-solucion/

    Has llegado a revisar el fichero config.inc.php?

    Saludos!

  5. HOLA MUCHAS GRACIAS, ME AYUDO MUCHO, SOBRE TODO AHORA QUE ESTOY TRABAJANDO CON LA VERSION 2.2A.
    SI HUBIESE SABIDO ESTO ANTES DE DESINSTALAR LA VERSION 2.1 DONDE ESTABA TODAS MIS BASES DE DATOS T_T . LOGICAMENTE PERDI TODA MI INFORMACION :S PORQUE DE LA NADA ME APARECIO QUE EL SOCKET ESTABA MAL BLA BLA BLA
    BUENO DE ANTEMANO, MUCHAS GRACIAS POR EL POST BUENISIMO.

  6. Adrian Perez says:

    Hola Julio,
    Me alegro que te haya servido de algo 🙂
    Gracias por el comentario!

  7. Fede says:

    Muchas gracias por la ayuda! Funciona.

  8. Adrian Perez says:

    Hola Fede, gracias por el comentario! Me alegro que siga siendo de ayuda el post.

  9. Petter Black says:

    Gracias, me has salvado, ese problema me salió en el Wamp y PhpMyAdmin, cambie lo que pusiste y me deja entrar de nuevo. Saludos

  10. Adrian Perez says:

    Me alegro de que el pequeño tip todavía sirva de ayuda. Saludos!

  11. Soledad says:

    Muchas gracias!
    En Windows no nos funcionó tal cual está acá, pero lo que hicimos solamente fue cambiar $cfg[‘Servers’][$i][‘connect_type’] = ‘tcp’; por ‘socket’ y salió andando!
    Saludos

  12. Adrian Perez says:

    Gracias Soledad por el apunte 🙂

  13. Noelia says:

    muchisimas gracias por el post!!!!!
    estoy teniendo exactamente el mismo problema pero en windows8 y sinceramente por mas que busco no se en que archivo debo de encontrar “$cfg[‘Servers’][$i][‘connect_type’] = ‘socket’”, si pudieran ayudarme se lo agradeceria.

    Un gran saludo

  14. Drupero novato says:

    C:\wamp\apps\phpmyadmin3.5.1

  15. Rock says:

    Hola, gracias por compartirnos tu conocimiento acerca del tema pero sabes? he intentado mil y un maneras de solucionar este problema y no doy con la respuesta. Instale Xampp para ubuntu 14.04 y todo esta bien hasta que quiero entrar a phpmyadmin. ya busque los el archivo de configuracion config.inc.php el cual por default Xampp lo instalo en “/opt/lampp/phpmyadmin” pero en ninguna parte del archivo encuentro las lineas que me comentas, sabes en que parte del archivo deberia de agregarlas?…. de antemano agradezco tu apoyo… Saludos.

  16. Adrian Perez says:

    Hola Rock,

    es difícil decirlo, ya que es posible que Xampp meta su propia parametrización.
    Primer consejo, no uses Xampp, menos en Ubuntu.

    No obstante, si quieres seguir adelante, es probable que algunas secciones no estén.. y tengas que añadirlas. Para poder seguir “algo” de modelo, siempre puedes bajarte la versión actual de PhpMyAdmin, descomprimirlo y observar su el contenido de este fichero o del modelo existente.

    De todas maneras de este modo es difícil, si lo prefieres mándame un email o un DM en Twitter e intentamos revisarlo.

  17. adri says:

    te amo me salvaste……….! graciasssssssss

  18. Michael Valle says:

    Hi,
    I am using wamp and mcafee… i did the change at file config.php and nothing happend.. i just disabled firewall macfee.. and it worked… thanks..!

Leave a Reply

Your email address will not be published. Required fields are marked *